Service Incident
Incident Report for Creditcall
Resolved
Fiserv (First Data) has informed us the incident affecting their services has been fully resolved.
Posted Sep 12, 2024 - 15:06 UTC
Identified
FiServ (FirstData) have informed us of an issue causing "service interruption to multiple applications" which may affect transaction processing. They have further advised "Progress is being made to resolve the incident". Updates will be provided as we receive them from FiServ.
Posted Sep 12, 2024 - 13:17 UTC
This incident affected: Processors - US/Canada (First Data Merchant Solutions (ISO8583 / Nashville), First Data Merchant Solutions (DL Host / Nashville), First Data Merchant Solutions (Rapid Connect)).