Service Incident
Incident Report for Creditcall
Resolved
This incident has been resolved.
Posted Sep 09, 2024 - 17:46 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2024 - 17:36 UTC
Investigating
We are currently investigating a potential service incident that may be impacting one or more functions of the NMI Payment Gateway (previously Creditcall). Some customers may be experiencing service issues as a result.
Posted Sep 09, 2024 - 17:10 UTC
This incident affected: Live Platform (Global - Merchant Plugin for 3-D Secure).