Batch Settlement Delays

Incident Report for Creditcall

Resolved

This incident has been resolved.
Posted Sep 22, 2026 - 10:55 UTC

Update

First Data Rapid Connect is recovering from an issue originating from Fiserv that affected batch settlement. Some customers may experience delays in associated funding. Our engineers are closely monitoring settlement processing to confirm that batches are settling as expected and the service remains stable.
Posted Sep 22, 2026 - 09:48 UTC

Monitoring

First Data Rapid Connect is recovering from an issue affecting batch settlement. Some customers may experience delays in associated funding. Our engineers are closely monitoring settlement processing to confirm that batches are settling as expected and the service remains stable.
Posted Sep 22, 2026 - 09:44 UTC