Service Incident - Tsys Sierra EMV

Incident Report for Creditcall

Resolved

This incident has been resolved.
Posted Oct 23, 2025 - 19:53 UTC

Identified

Tsys are investigating an ongoing issue on the Tsys Sierra platform causing communications failures. Customers may experience delays in authorisation processing. Further updates will be provided when available.
Posted Oct 23, 2025 - 16:40 UTC
This incident affected: Processors - US/Canada (TSYS (Sierra)).